Author Topic: Problem installing to run a data report  (Read 3706 times)

jojom

  • Guest
Problem installing to run a data report
« Reply #5 on: August 11, 2006, 07:17:07 AM »
Thanks a lot for the timely answer to my query.
I will try Inno script.thanks a lot

Randem

  • Administrator
  • Hero Member
  • *****
  • Posts: 2618
Problem installing to run a data report
« Reply #4 on: August 10, 2006, 12:10:30 PM »
jojom,
 
PDW does not find all the dependencies for your project all the time and it hasn't been updated since 1997. You can try InnoScript along with Inno Setup to create an installation package and it will be complete. InnoScript is free for three days, Inno Setup is completely free.
 
You are not supposed to include any source code in your setup. i.e. forms, modules or classes.
 
You can download InnoScript from https://randemsystems.com
and Inno Setup from http://www.jrsoftware.org

jojom

  • Guest
Problem installing to run a data report
« Reply #3 on: August 10, 2006, 06:17:13 AM »
Hi,
   I would like to know whether frm files are tobe included in the PDW besides exe files.
The source code is visible when the form file in the installed folder is opened using VB IDE.
What shold be done to make the source code not visible?

Randem

  • Administrator
  • Hero Member
  • *****
  • Posts: 2618
Problem installing to run a data report
« Reply #2 on: April 18, 2006, 08:39:04 AM »
Aloha satkin,
 
Your problem is most likely in your Connection String. You probably have it hard coded as to the location of the database on your development system. The location would not be the same on your target systems. You need to make your connection string dynamic possibly by using App.Path to get the path of your installed app and have the database installed in the same path as your app. That would be one solution.
 
Check the source in your data reports. You can change it through code.

satkin

  • Guest
Problem installing to run a data report
« Reply #1 on: April 18, 2006, 01:41:57 AM »
Hi,
I have created a vb programme that links to a back end access database.  In my programme I am tables to add, alter etc fine, but when I run the data report it fails.
 
I think that this must be a problem with the way I have got my setup programme working as it works fine when I test the system.  It only fails when installing onto a different machine.
 
I have used the following required files as the package & development wizard in VB6 would use, so think that I am passing all of the files.  
 
File - Destination
-------------------------------------------
MyProg.exe - application path
MyDb.mdb - application path
dao360.dll - system path
MDAC_TYP.exe - app path
msado25.tbl - system path
msadodc.ocx - system path
msbind.dll - system path
mscomct2.ocx - system path
mscomctl.ocx - system path
msdbrptp.dll - system path
msderun.dll - common files/designer
msstdfmt.dll - system path
 
I'm not sure why I'm going wrong.  Any help or advice on the setup required for data reports would be most appreciated.
 
Thanks
 
S Atkin